Timeout bei der Synchronisation
FAQ-Nr: OKB-000216
Problem:
Beim Synchronisationsvorgang erscheint die Meldung:
Der Prozess wartet auf eine Antwort von der Abfrage '{call sys.sp_Msmakegeneration (?)}
und dann die Meldung:
Vom Mergeprozess konnte eine Abfrage nicht ausgeführt werden, da für die Abfrage ein Timeout aufgetreten ist. […]
Ursache:
Ein interner, nicht näher spezifizierter Fehler in der Microsoft SQL-Replikation.
Lösung:
Führen Sie die folgende SQL-Abfrage auf Ihrer Abonnement-Datenbank (z.B. aus dem Management Studio) aus:
update sysmergepublications set [generation_leveling_threshold] = 0
und starten Sie den Synchronisationsvorgang erneut.
Weitere Informationen finden Sie auf den folgenden Seiten: